Degraded performance
Resolved
Jun 23, 2026 at 8:43pm UTC
This incident is now resolved. Performance has returned to normal and all services are operating as expected. Thank you for your patience while we worked through this.
Affected services
Updated
Jun 23, 2026 at 8:38pm UTC
Performance is returning to normal and most users should see things working as expected. We're continuing to monitor closely and finishing up the remaining work before we consider this fully resolved.
Affected services
Updated
Jun 23, 2026 at 8:24pm UTC
We've identified the issue and are working on a fix. As we apply it, there may be a short period of downtime. We expect to have everything back to normal shortly and will post an update once resolved.
Affected services
Created
Jun 23, 2026 at 7:56pm UTC
We're currently experiencing degraded performance due to elevated database load. Some users may notice slower response times or intermittent errors while accessing parts of the platform. We're working to resolve it and will provide updates as soon as possible.
Affected services